Unable to do a Cutover migration? your Exchange on prem is too outdated? Do the PST Network Upload! to Exchange Online using the AzCopy tool

I have great news! turns out the AzCopy tool works fine! I just tested it in two different tenants!

My first attempt didn’t go thru because of the VPN’s i use from this machine.

My second attempt didn’t go thru either because I had not given myself Import Export permissions by doing the steps below:

There is a part for which they provide no documentation and that is on how to grant yourself the Import export permissions:
• Log on to http://portal.microsoftonline.com with O365 Administrator credentials
• At the tabs at the top hit on Admin and select Exchange
• In Exchange admin center select Permissions > admin roles
Double click Discovery Management
Under Roles Click on Add and Select Mailbox Import Export
Under Member, Add yourself (Global Admin account is a MUST) as a Member and Click Save.
My third attempt from my PC that has no VPNs worked just fine my uploads didn’t time out and the data was upload right into the INBOX, Sent, Drafts, e,t,c as I chose not to send it as an archive since that’s what you want but I may be testing the upload as archive as the switch is really just True/False for whether you want it in the the Archive or Not.

Let me know if you will have a way to test this out but please make sure you assign the Mailbox Import Export permissions!

attached I’ve sent the users2.csv template that I have been using works great.

A sample of the powershell I run to do the upload.

and some screen shots showing the actual success and errors from the tenant which permissions are still pending the 24 hour propagation.

Click here to see the PowerShell sample

CSV template sample: users2

Step by step guide to using the aZcopy tool:

Do the permissions from this article below:

How to do In-place eDiscovery in new O365?



Leave a Reply

Your email address will not be published. Required fields are marked *